hotrannam's corner

I enjoy building apps that people love

Rails3: Getting started with a weird error

leave a comment »

I came across errors in installing rails with version 3.0.0 in today. The error message said that ‘mail requires i18n (~> 0.4.1, runtime)’. This is story of versions and it is not new in OSS at all. It has been discouraging who are not only beginners.

Some guys suggested installing i18n version 0.5.0 before rails. OK, it helps you get through the error. But wait, you will continue getting another error when creating a new rails application. Rails will complaint versions of gem i18n, 0.5.0 and 0.4.2. Some gems depend on 0.5.0 and others depend on 0.4.2.

Mail gem depends on version 0.5.0 of i18n. Taking a look at version of this gem, the version 2.2.11 is just updated in recent days, Nov 29, 2010. My experience in installing rails version 3.0.0 before had no these errors. I tried to install the previous version of mail gem, 2.2.10. I also checked version of dependencies at here. As you may see, the version 2.2.10 of mail gem requires version i18n gem greater than 0.4.1. So I thought choosing the version 0.4.2 of i18n will match requirement of other gems, and mail gem version 2.2.10 as well.

The following are steps to install.

  • gem install i18n -v=0.5.0
  • gem install rails -v=3.0.0
  • gem uninstall i18n (choose version 0.5.0 to uninstall)
  • gem uninstall mail
  • gem install mail -v=2.2.10
  • rails new hello_app

Hope this helps.

Advertisements

Written by Nam

December 4, 2010 at 4:03 pm

Posted in Ruby On Rails

Tagged with

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: